Alleva Echo - Slow processing or transcription issues

Incident Report for Alleva Status Page

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 15:03 MDT

Update

We continue to work with our partner on this issue and will provide an update as soon as the issue has been identified an update completed.
Posted Sep 08, 2026 - 17:03 MDT

Investigating

We are working with our partner to help address the issues that some users may experience with Echo. Thank you for your patience and understanding as we work to identify the root cause.
Posted Sep 08, 2026 - 14:40 MDT
This incident affected: Features (Echo).