Alleva Live Chat Support / Support email Unavaliable

Incident Report for Alleva Status Page

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 11:24 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2026 - 10:59 MDT

Investigating

We are currently aware of an 3rd party issue with our Live chat / email provider. They are currently working to address it as quickly as possible. In the meantime if you need to reach our support team please call 877.425.5382, Option #2. Thank you.
Posted Sep 08, 2026 - 10:15 MDT
This incident affected: Alleva Live Chat.