All systems are now operational. The system will continue to catch up with older reports until it is caught up.
Posted Oct 03, 2025 - 17:03 MDT
Monitoring
We have deployed the fix and we are seeing normal processing of reports / dashboards. You may get some additional or backlogged reports / emails. We continue to monitor to ensure that all systems operate as expected.
Posted Oct 03, 2025 - 14:56 MDT
Update
We are working with the provider to make necessary changes overnight tonight. In addition to that we are working to adjust times of some of the jobs run to improve the efficiency. We will provide another update by tomorrow morning as those adjustments are put in place.
Posted Oct 01, 2025 - 15:14 MDT
Identified
We have identified the current causes and are working to address the issues with our 3rd party partner. We have corrected the issue with dashboards / reports loading directly within insights but are still working on the scheduled reports.
Posted Oct 01, 2025 - 09:07 MDT
Update
We are continuing to work to identify the cause and work on the potential solution. We are getting reports that insights may not be loading for some users. We apologize for the inconvenience this may cause and know that we are working diligently to resolve.
Posted Sep 30, 2025 - 15:00 MDT
Investigating
The issue has returned this morning and the teams have responded and working to resolve with our 3rd party provider the issue. We apologize for the inconvenience and understand that you can download the required reports in the short term while we work to resolve the automation of sending reports.
Posted Sep 30, 2025 - 11:28 MDT
Monitoring
We have been working with our 3rd party partner to address this and we have seen some clear through the backlog. We will continue to monitor the situation and the new set of schedules to run Tuesday morning.
Posted Sep 29, 2025 - 17:39 MDT
Investigating
We are currently investigating with our 3rd party partner the delay in scheduled reports this morning. All other insights functions are functioning normal it is only related to sending scheduled or one off reports.