Degraded Client List Performance

Incident Report for Alleva Status Page

Resolved

We've located the cause of the degraded functionality and it's been resolved.
Posted Jun 05, 2025 - 15:24 MDT

Investigating

We are currently investigating an issue centered around the performance of the Client List. Some users may be unable to access the client list at this time.
Posted Jun 05, 2025 - 12:42 MDT
This incident affected: Core Functions (Client List).