The incident has been resolved. The initial findings was an AwS hardware issue with our 3rd party provider. We thank you for your patience and understanding today.
Posted Apr 04, 2025 - 19:52 MDT
Update
We are continuing to monitor for any further issues.
Posted Apr 04, 2025 - 16:47 MDT
Update
We are continue to work on the situation and restoring full functionality. Thank you for your patience and understanding as our 3rd party and AWS work to restore services.
Posted Apr 04, 2025 - 14:24 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2025 - 13:29 MDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2025 - 12:48 MDT
Investigating
We are receiving reports that e-prescribe is either slow or not functioning correctly. We are working with our 3rd party provide to resolve as quickly as possible.
Posted Apr 04, 2025 - 11:50 MDT
This incident affected: Integrations (E-Prescribe).