Alleva Insights Reporting

Incident Report for Alleva Status Page

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 19:00 MDT

Monitoring

Currently there is a google cloud outage that is impacting the Alleva Insights reporting product. Some reports / dashboards may not be available and unable to create new reports. We are currently monitoring the situation with google and will update as soon as information becomes available.
Posted Jun 12, 2025 - 13:56 MDT
This incident affected: Features (Insights).