Alleva EMR - Degraded Performance / Login Issues

Incident Report for Alleva Status Page

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 12:03 MDT

Monitoring

Performance levels are increasing and we are continue to monitor the situation to ensure proper resolution.
Posted Sep 02, 2025 - 10:57 MDT

Investigating

We are currently investigating the issue being reported of slow loading times, time out's, and login issues. The response teams are currently working to identify the root cause of the issue.
Posted Sep 02, 2025 - 09:55 MDT
This incident affected: Core Functions (EMR Core, Client List) and Features (System Settings, User Management).